php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #19277 Shortcut to receive the latest PHP Version
Submitted: 2002-09-07 08:18 UTC Modified: 2013-06-05 17:21 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pvo99 at gmx dot ch Assigned: danbrown (profile)
Status: Closed Package: Website problem
PHP Version: 4.2.3 OS:
Private report: No CVE-ID: None
 [2002-09-07 08:18 UTC] pvo99 at gmx dot ch
Is it eventually possible to add a shortcut which would display the latest php version in a very simple format, so that everyone can query this site with his own scripts and
display the newest php version on his own website?

The shortcut could be, for example http://php.net/latestVersion

Kind Regards
Phil

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-07 21:05 UTC] kalowsky@php.net
No because this is the shortcut used for finding functions.  Not a good practice to mix the two.
 [2002-09-08 04:16 UTC] pvo99 at gmx dot ch
And what about a .txt File placed on the Server, containing the Latest Version ?

for example http://www.php.net/latestVersion.txt
with the Content:
4.2.3
 [2002-09-08 06:05 UTC] sander@php.net
Don't know what's wrong about the idea of such a shortcut. We have more shortcuts to non-function pages, e.g. http://php.net/phpdochowto. Reopening.
 [2010-11-19 01:01 UTC] jani@php.net
-Package: Feature/Change Request +Package: Website problem
 [2013-06-05 17:21 UTC] danbrown@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: danbrown
 [2013-06-05 17:21 UTC] danbrown@php.net
No discussion in nearly eleven years suggests that it's not a highly-desirable 
feature.  Besides, with a small bit of coding, the latest version can always be 
obtained via automation if that's the goal.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 09:05:52 2022 UTC