php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19202 environment variable PHPRC not used
Submitted: 2002-08-30 14:08 UTC Modified: 2002-08-30 17:46 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: phpbug083002 at smayw dot nask dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.2.2 OS: RedHat 7.2
Private report: No CVE-ID: None
 [2002-08-30 14:08 UTC] phpbug083002 at smayw dot nask dot com
I set the environment variable PHPRC using:

	SetEnv PHPRC /etc/httpd/conf/aktualnosci.tras.pl

and create a /etc/httpd/conf/aktualnosci.tras.pl/php.ini file:

-rw-r--r--    1 root     root           96 Aug 30 18:29 /etc/httpd/conf/aktualnosci.tras.pl/php.ini

containing:

open_basedir    =/home/web1/aktualnosci.tras.pl:/tmp
doc_root        =/home/web1/aktualnosci.tras.pl/www

I am sure the variable gets set (http://aktualnosci.tras.pl/php.sphp) but the config file used remains at the default, and none of the options set in the ini file get modified - looks like the file is not looked at, basically ignored.  Help :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-30 17:46 UTC] sniper@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.


Hint: It's a shell environment variable..set it before starting apache..

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 18 20:05:44 2022 UTC