php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19171 php_vale auto_prepend_file in VirtualHost
Submitted: 2002-08-29 08:39 UTC Modified: 2002-08-29 08:54 UTC
From: pigo at pchome dot com dot tw Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.2.2 OS: Red Hat Linux 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pigo at pchome dot com dot tw
New email:
PHP Version: OS:

 

 [2002-08-29 08:39 UTC] pigo at pchome dot com dot tw
In Apache
<VirtualHost> Setting use php_value auto_prepend_file xxxx.php .
Then test a HTML file(Write Some XML in it)
it always show php parse error.

Because it will run xxxx.php , then handle HTML file.

but why HTML file will be php handle ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-29 08:54 UTC] edink@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.
 [2002-08-29 23:46 UTC] pigo at pchome dot com dot tw
Is this a bug or not ?

My httpd.conf setting is
AddType application/x-httpd-php .php .phtml .inc .php3

if  <VirtualHost>  set "php_value auto_prepend_file header.inc",All HTML files will run header.inc first .

So all HTML files will be a php script.
All HTML files with XML tag will show php parse error.
Is it a bug or not ?
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 22:01:28 2024 UTC