php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19163 PEAR::Auth::setAuth() wrong call
Submitted: 2002-08-28 19:00 UTC Modified: 2002-08-29 13:10 UTC
From: arnaud at limbourg dot com Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.2.1 OS: Winnt 4 & Linux
Private report: No CVE-ID: None
 [2002-08-28 19:00 UTC] arnaud at limbourg dot com
I have written my own container for Auth based on a quick post from Martin a while back (february or march i think) in which i make a static call to setAuth (Aut::setAuth())

In the latest cvs version setAuth now calls setAuthData.

The problem is that the call is made using the $this-> structure.

But in that case that cannot work since the call to setAuth is static.

The call to setAuthData() should be static

        if (!empty($data)) {
            Auth::setAuthData($data);
        }

Arnaud.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-29 13:10 UTC] mj@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 30 15:01:23 2021 UTC