php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19118 $HTTP_POST_VARS
Submitted: 2002-08-27 03:10 UTC Modified: 2002-10-05 06:09 UTC
From: yamasaki at aero dot kyushu-u dot ac dot jp Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4CVS-2002-08-27 OS: Solaris 8
Private report: No CVE-ID: None
 [2002-08-27 03:10 UTC] yamasaki at aero dot kyushu-u dot ac dot jp
I am using php-4.2.3RC1.
For the sample program (attached bug.php), after pushing
'New' button, it shows up 'cmd:Newcmd=New' instead of
'cmd:New'. Is it a bug ?
-------------------------------------
<html>
<head>
</head>
<body>
<form method="post" name="submit" action="bug.php">
<input type="submit" name="cmd" value="New">
</form>
<?php
if (isset($HTTP_POST_VARS)) {
   foreach ($HTTP_POST_VARS as $key => $value) {
      print $key . ":" . $value . "<BR>";
   }
}
?>
</body>
</html>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-27 03:13 UTC] rasmus@php.net
Is this Apache2?  If so, that's your problem.
 [2002-08-27 03:44 UTC] yamasaki at aero dot kyushu-u dot ac dot jp
Thank you for your reply.
Yes, it is Apache2.
Will you kindly give the pointer to fix my problem ?
 [2002-08-27 03:45 UTC] rasmus@php.net
We do not support Apache2 in PHP 4.2.x.  Try the latest CVS snapshot of 4.3-dev from snaps.php.net or use Apache 1.3.x
 [2002-08-27 04:15 UTC] yamasaki at aero dot kyushu-u dot ac dot jp
The version I obtained by

cvs -d :pserver:cvsread@cvs.php.net:/repository co php4

gives the same result. Is this the right 4.3-dev ?
 [2002-08-27 10:31 UTC] rasmus@php.net
Opened back up since it is also in current CVS - unverified
 [2002-09-30 19:45 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip

I am unable to replicate this bug using latest CVS.
 [2002-10-01 01:05 UTC] yamasaki at aero dot kyushu-u dot ac dot jp
Thank you for the testing.
Still I have the problem in the current CVS version.

apache 2.0.42
Solaris 8
gcc version 2.95.2
Configuring by

                ./configure \
                --enable-trans-sid --enable-mbstring --enable-mbstr-enc-trans \
                --enable-track-vars --enable-force-cgi-redirect \
                --with-mysql=/usr/local/mysql
 [2002-10-04 16:48 UTC] iliaa@php.net
I do not see --with-apxs2 in your configure line, are you using php-cgi with Apache 2?
 [2002-10-05 03:14 UTC] sander@php.net
You are probably using the Input- and OutputFilter directives. You shouldn't. Just use LoadModule & AddType.
 [2002-10-05 06:09 UTC] yamasaki at aero dot kyushu-u dot ac dot jp
Sorry, I have mispasted the configure line.

It should read

                ./configure --with-apxs2=/usr/local/apache2/bin/apxs \
                --enable-trans-sid --enable-mbstring --enable-mbstr-enc-trans \
                --enable-track-vars --with-mysql=/usr/local/mysql
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 07:03:34 2022 UTC