php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19062 Display Sablotron version number to help diagnose problems
Submitted: 2002-08-23 01:22 UTC Modified: 2002-08-23 07:14 UTC
From: pmoulding at tedis dot com dot au Assigned:
Status: Closed Package: Sablotron XSL
PHP Version: 4.2.2 OS: Solaris and Linux
Private report: No CVE-ID: None
 [2002-08-23 01:22 UTC] pmoulding at tedis dot com dot au
I use PHP XSLT on Solaris, Linux, NT, and Windows 2000. On NT and Windows 2000 the version of Sablotron is usually in sync with PHP because they are installed form the same binary. On Linux and Solaris they may be miles apart because Sablotron is not automatically updated with PHP. phpinfo() does not display the Sablotron release so I do not know if the problems are caused by Sablotron being out of date. In cased where I do not have administrative access, 78.45301% of the time, I cannot tell why Sablotron is refusing to process XSLT that works on other servers.

If phpinfo() reported the Sablotron release, that would be a help. The alternative might be an xslt_info().

One thing I noticed on a server with a recent PHP, one that uses the new XSLT interface to Sablotron, and an older version of Sablotron, was the lack of error messages. There were many cases where the XSLT process returned false but there were no error messages. I ripped out a few hairs before realising it might be an old Sablotron release.

If this suggestion is not feasible then perhaps we could have a note on the PHP XSLT page along the lines of "PHP 4.2.2 tested with Sablotron 0.95".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-23 07:14 UTC] sniper@php.net
Someone just recently added  xslt_backend_version() and
xslt_backend_name() in CVS..just try this snapshot:

http://snaps.php.net/php4-latest.tar.gz



 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 20:01:29 2024 UTC