php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19018 net_socket class ???
Submitted: 2002-08-21 08:44 UTC Modified: 2002-08-22 09:10 UTC
From: giosif at ase dot ro Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.2.2 OS: Linux (Slackware 8.1)
Private report: No CVE-ID:
 [2002-08-21 08:44 UTC] giosif at ase dot ro
Hi ! I'm using PHP 4.2.2 and Apache 1.3.26. I want to use Horde+Imp for webmail and it works fine but I have problems when trying to send mail - I get the next error messages (in Apache's error_log file):

[error] PHP Warning:  Failed opening 'Net/Socket.php'
for inclusion (include_path='.:/usr/local/lib/php') in
/usr/local/lib/php/Net/SMTP.php on line 93
[error] PHP Fatal error:  Cannot instantiate
non-existent class:  net_socket in /usr/local/lib/php/Net/SMTP.php on line 95

My configure line looks like this:

./configure --with-apache=(path to apache 1.3.26 source) --with-bz2 --with-ttf --with-gettext --with-imap=(path to imap source) --with-mysql

 Can you tell me if this is a bug or I have to study more...

  Thank you !

 George Iosif

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-21 10:32 UTC] arnaud at limbourg dot com
You need to install the PEAR:NET::Socket class.

Do a pear install Net_Socket

To get the pear command do something like lynx -source
"http://pear.php.net/go-pear" | php -q

Arnaud.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC