php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19013 failure during make install
Submitted: 2002-08-21 04:29 UTC Modified: 2003-01-20 17:23 UTC
From: eelco_dotinga at planet dot nl Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.2.2 OS: AIX 4.3.3 ML10
Private report: No CVE-ID: None
 [2002-08-21 04:29 UTC] eelco_dotinga at planet dot nl
Output from make install, had the same error in 4.2.2.

Making install in .
make[1]: Entering directory `/usr/local/install/php4-STABLE-200208200600'
/usr/local/apache2/bin/apxs -i -a -n php4 libphp4.la
/usr/local/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la /usr/local/apache2/modules
rm -f /usr/local/apache2/modules/libphp4.so
/usr/local/apache2/build/libtool --mode=install cp libphp4.la /usr/local/apache2/modules/
cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish /usr/local/install/php4-STABLE-200208200600/libs'
mv: 0653-401 Cannot rename /usr/local/apache2/modules/libphp4.so.0 to /usr/local/apache2/modules/libphp4.so:
             A file or directory in the path name does not exist.
chmod 755 /usr/local/apache2/modules/libphp4.so
chmod: /usr/local/apache2/modules/libphp4.so: A file or directory in the path name does not exist.
apxs:Error: Command failed with rc=65536
.
make[1]: *** [install-sapi] Error 1
make[1]: Leaving directory `/usr/local/install/php4-STABLE-200208200600'
make: *** [install-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-21 09:10 UTC] kalowsky@php.net
Duplicate of many of AIX install bugs.  Please take a look at them, and add to them instead of opening a new one.  
 [2002-08-21 10:17 UTC] eelco_dotinga at planet dot nl
Ok
 [2003-01-20 17:23 UTC] sniper@php.net
This is the one: http://bugs.php.net/bug.php?id=14245
I'm marking this as bogus now, please follow the above
report for any updates.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 08:01:24 2020 UTC