php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #18993 arg_separator
Submitted: 2002-08-20 15:33 UTC Modified: 2002-08-26 12:18 UTC
From: ggodlewski at wi dot ps dot pl Assigned: spic (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 4.2.2 OS: Linux
Private report: No CVE-ID: None
 [2002-08-20 15:33 UTC] ggodlewski at wi dot ps dot pl
The documentation says:
A more portable way around this is to use & instead of & as the separator. You don't need to change PHP's arg_separator for this
Whereas I have to set arg_separator to & in my php.ini

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-20 16:01 UTC] ggodlewski at wi dot ps dot pl
The documentation says:
A more portable way around this is to use & instead of & as the
separator. You don't need to change PHP's arg_separator for this
Whereas I have to set arg_separator to ;& in my php.ini
 [2002-08-26 08:12 UTC] spic@php.net
Where in the Documentation does this error occur???
I found the expression at the urlencode-Doc. Is this correct??? Could you describe the bug a bit more detailed???
 [2002-08-26 08:25 UTC] mk@php.net
Perhaps changing this sentence to "A more portable way around this is to use & instead of & as the separator (which is the default setting in php.ini)" will solve the problem. 
 [2002-08-26 09:07 UTC] ggodlewski at wi dot ps dot pl
I've found it at http://www.zend.com/manual/function.urlencode.php
Description at:
http://www.php.net/manual/en/function.urlencode.php
is wrong as well:
"You don't need to change PHP's arg_separator for this"
arg_separator _has_ to be set to achive this behaviour.
When I upgraded to 4.2.2 my scripts stop working. Instead of "aa" I got strings like "amp;aa". After setting the arg_separator which doesn't need to be changed (according to description) everything is ok.
 [2002-08-26 09:50 UTC] spic@php.net
I will fix it as soon as possible. 
 [2002-08-26 12:09 UTC] spic@php.net
After re-investigating the doc, I could not reproduce the error using a test-script that encoded and decoded a string "?test=one&test=two" with $cstr=htmlentities(urlencode($str)); with and without changing arg_separator.

 [2002-08-26 12:18 UTC] sniper@php.net
arg_separator.input and arg_separator.output have nothing
to do with urlencode() & friends. Please read the comments
in php.ini-dist about what they are meant for..


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 01:01:23 2020 UTC