php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #189 mysql_connect and SAFE_MODE question
Submitted: 1998-03-19 10:50 UTC Modified: 1998-03-21 06:01 UTC
From: DelislMa at CollegeSherbrooke dot qc dot ca Assigned:
Status: Closed Package: MySQL related
PHP Version: 3.0b5 OS: Linux 2.0.33
Private report: No CVE-ID: None
 [1998-03-19 10:50 UTC] DelislMa at CollegeSherbrooke dot qc dot ca
I would like to know why in SAFE_MODE, I can't use any 
username in mysql_connect? My project would request a
username/password via an authentication dialog box and use it 
to make the connection to the sql server.

I am using PHP3 as an Apache module.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-03-21 06:01 UTC] zeev
This is not a bug, but a feature.  In SQL safe mode, you
can't open MySQL links with arbitary usernames - only
the username owning the file being parsed (the parent file,
if there are includes).

Just set sql_safe_mode to 0 if that's not what you want.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 16:01:26 2019 UTC