php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18820 Configure detects wrong apache version w/ C2Net Stronghold
Submitted: 2002-08-08 20:47 UTC Modified: 2002-09-21 01:53 UTC
From: jmorton at ezrez dot com Assigned:
Status: No Feedback Package: PHP options/info functions
PHP Version: 4.2.2 OS: Debian GNU/Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-08-08 20:47 UTC] jmorton at ezrez dot com
When running C2Net Stronghold 2+, PHP detects the wrong version of Apache (Since Stronghold outputs "Stronghold/3.0" in -v).

I saw other bugs similar to this problem, but not quite the same (Such as Bug #16791)

A diff of what I did to make it work: (No guarantee this is safe for versions of Stronghold other than 3.0)

3658c3658,3664
<   if test "$APACHE_VERSION" -ge 2000000; then
---
>   APACHE_VENDOR=`$APXS_HTTPD -v | head -1 | cut -f3 -d' ' | cut -f1 -d'/'`
>   if test "$APACHE_VENDOR" == "Stronghold"; then
>       APACHE_VERSION_NUMBER=5000000;
>   else
>       APACHE_VERSION_NUMBER=2000000;
>   fi
>   if test "$APACHE_VERSION" -ge $APACHE_VERSION_NUMBER; then
3661d3666
<


-ge 5000000 since RedHat has already released Stronghold 4.0, and it's still based on Apache 1.3.x

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-14 17:46 UTC] sniper@php.net
Please try the latest (NON-stable) CVS snapshot from http://snaps.php.net/ as I think this is already fixed.

 [2002-09-21 01:53 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 18:01:27 2024 UTC