php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18693 gettext doesn't work on Windows with PHP 4.2.x
Submitted: 2002-08-01 18:40 UTC Modified: 2002-08-05 12:43 UTC
From: spam at dubbekarl dot dk Assigned: edink (profile)
Status: Closed Package: Gettext related
PHP Version: 4.2.2 OS: Windows 2000
Private report: No CVE-ID: None
 [2002-08-01 18:40 UTC] spam at dubbekarl dot dk
When I use the old version of PHP (4.1.2) available from Windows, the gettext functions work perfectly but not when I use any of the 4.2.x versions of PHP. No error messages are given, it seems to me that _() just returns its argument without i18n'ing it.

The 4.1.2 version is bundled with gnu_gettext.dll but 4.2.x is not. Using the 4.1.2 version of that dll in 4.2.x doesn't fix the problem.

I described the problem many times on PHP forums but noone has helped me so I will guess it is a bug.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-05 12:43 UTC] edink@php.net
The problem is resolved. You can download http://ftp.proventum.net/pub/php/win32/temp/php_gettext-4.2.2.zip archive which contains two files. You should replace php_gettext.dll in your php4\extensions dir with the file from the archive and put libintl-1.dll in you \windows\system32 folder.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 11:01:24 2020 UTC