php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18600 Unable to create Java Virtual Machine
Submitted: 2002-07-26 13:06 UTC Modified: 2003-10-29 12:41 UTC
Votes:66
Avg. Score:4.7 ± 0.7
Reproduced:55 of 55 (100.0%)
Same Version:38 (69.1%)
Same OS:43 (78.2%)
From: nalves at equifax dot com dot br Assigned:
Status: Not a bug Package: Java related
PHP Version: 4.3.3 and 5.0.0-dev OS: Windows 2000
Private report: No CVE-ID: None
 [2002-07-26 13:06 UTC] nalves at equifax dot com dot br
As I couldn?t get a definitive answer for this, I?m posting a new bug.

I can?t make the Java extension work. It runs fine for some time, but after some time I just get the message "Unable to Create Java Virtual Machine". If I make a lot of connections (just pressing the F5 key) I can reproduce the error. After this error, I might be succesful in another execution, but not always.

I?m using Java 1.4.0_01.
My php.ini is configured like this:
java.class.path = c:\PHP\extensions\php_java.jar
java.home = "C:\j2sdk1.4.0_01"
java.library = "C:\j2sdk1.4.0_01\jre\bin\server\jvm.dll"

Even setting java.home to C:\j2sdk1.4.0_01\bin would not work. I even tried PHP 4.1.2 + jdk1.2.2, but it reported the same behavior.

Any help would be appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-07 03:51 UTC] lebeau dot frederic at skynet dot be
THANKS TO Alberto.Sarini@libero.it ,
The solution to resolve "Unable to Create Java Virtual
Machine" is to configure APACHE or IIS not using sapi for php but CGI

THANKS THANKS THANKS

go there for configuration
http://hotwired.lycos.com/webmonkey/00/44/index4a_page9.html?tw=programming
 [2003-08-15 21:36 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug #16690
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 08:01:26 2019 UTC