php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18574 virtual() seg faults
Submitted: 2002-07-25 13:57 UTC Modified: 2003-02-03 11:40 UTC
From: roshan_naik at hp dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.2 OS: HPUX 11.00
Private report: No CVE-ID: None
 [2002-07-25 13:57 UTC] roshan_naik at hp dot com
When virtual() function is invoked with a php file passed as argument, server seg faults. Seg faulting takes place only in apache 2.0 and not 1.3

Note: On the other hand, the documentaion says explicitly, that php files should not be passed to virtual. But i guess segfaulting is not the right way to handle this error condition. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-25 14:00 UTC] sniper@php.net
reclassified
 [2002-07-25 14:00 UTC] sniper@php.net
fixed typo in the short summary..

 [2002-07-26 01:58 UTC] rverlander@php.net
PHP modules for Apache 2.0 is E-X-P-E-R-I-M-E-N-T-A-L
I recommend that you either use PHP in CGI mode OR you use Apache 1.3
 [2002-10-09 14:29 UTC] iliaa@php.net
Dupe of #17868.

Doing virtual('script.php'); inside a PHP script or calling 
<!--#include virtual="script.php"--> within the a page more then once causes a crash.
 [2003-02-03 11:40 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 21:05:46 2022 UTC