php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18513 PHP4 crashes as NSAPI
Submitted: 2002-07-23 17:13 UTC Modified: 2002-10-24 01:00 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: mbagepll at memphis dot edu Assigned:
Status: Closed Package: iPlanet related
PHP Version: 4.2.1 OS: Windows 2000
Private report: No CVE-ID: None
 [2002-07-23 17:13 UTC] mbagepll at memphis dot edu
I am not sure if this is a bug, but i am trying to install php4 on windows 2000 as NSAPI. I followd the instructions from the web page -- http://benoit.noss.free.fr/php/install-php4.html#step1, to install php4 as nsapi. But, when i start the server, it crashes. Please let me know if there is something i need to do to make this work. Or, if this is a bug, is there a patch that would fix this? 

Madhavi

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-24 11:30 UTC] mbagepll at memphis dot edu
Has anybody got php4 working on windows 2000 with iplanet (NSAPI)?
 [2002-07-26 13:23 UTC] lbalbalba at hotmail dot com
Ive experienced almost exactly the same problem on AIX 4.3.3/iPlanet 4.x when I compile as an nsapi module. Note that PHP works quite nicely on AIX when compiled as an CGI executable, or when compiled as an Apache 1.3.x. DSO module. On Linux though, with the *exact* same iPlanet and PHP versions, things actually work as expected when built as an nsapi module. See also Bug-15439 for more details.
 [2002-08-06 14:39 UTC] mbagepll at memphis dot edu
I have got it working on solaris 8 with the same iplanet but could not get it working for windows 2000. I have been trying this since 3 weeks. I still not sure what needs to be done.
 [2002-10-08 22:41 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-10-08 23:49 UTC] kalowsky@php.net
Just a comment, while I've done some work on the NSAPI for unix, I haven't touched the Windows dsp files.  Someone with more Windows knowledge would be better suited to check this.  
 [2002-10-24 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2021-04-06 10:40 UTC] git@php.net
Automatic comment on behalf of roojs
Revision: https://github.com/php/pecl-tools-svn/commit/0dc053866d00221cd162ef7a0a0baa80239dc049
Log: fix bug #18513 - svn_info( working_copy, false, SVN_REVISION_UNSPECIFIED ) gives you a svn_info on the local copy
 [2021-04-06 10:40 UTC] git@php.net
-Status: No Feedback +Status: Closed
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 23:01:29 2024 UTC