php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18433 Integer values are broken when retrieved through a ODBC connection
Submitted: 2002-07-19 06:07 UTC Modified: 2002-07-19 06:09 UTC
From: Daniel Gollub <dgollub at lis-ag dot de> Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 4.1.2 OS: Windows 2000 Server
Private report: No CVE-ID: None
 [2002-07-19 06:07 UTC] Daniel Gollub <dgollub at lis-ag dot de>
Hello,

sorry, if this bug is already somewhere in the list, but I didn't found it than...

briefly my config:

PHP-Version: 4.1.2 (installed as CGI)
Webserver: IIS 5 on a Win2k Server, SP2 installed
ODBC-Driver Version for MS-SQL Server: 3.70.09.61

And here is the BUG:

When I try to get timestamp values from a MSSQL 2000 server over ODBC via PHP, then I get these results (using var_dump()):

["session_start"]=> string(17) "1.027.070.2t?" ["session_time"]=> string(17) "1.027.071.2t?" 

session_start and session_time are int(4) fields within the database! The QueryAnalyser from MS returns the correct value "972086460" or something similar.

Same for the user_id (int(4) in the DB):

["user_id"]=> string(5) "1,00"

So, I wonder if this a pure ODBC bug or a PHP(-ODBC) bug or what is it? Any ideas?

I'm just trying to get the good old phpBB forum to work in our local intranet.

PS: I know my English suxx... Shit happens. ;-)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-19 06:09 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 [2002-07-19 06:09 UTC] Daniel Gollub <dgollub at lis-ag dot de>
What I missed: we are using ODBC because we can't connect to the server directly. Just in case you are curios.
 [2002-07-19 06:09 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 05:05:45 2022 UTC