php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #18207 .tar.bz2..bz2
Submitted: 2002-07-07 07:54 UTC Modified: 2002-07-08 07:34 UTC
From: thochgreve at php-resource dot de Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 4.2.1 OS: win98se
Private report: No CVE-ID: None
 [2002-07-07 07:54 UTC] thochgreve at php-resource dot de
I just downloaded php_manual_de.tar.bz2 via IE5.0 (version 5.00.2614.3500)
and receive a file named php_manual_de.tar.bz2..bz2

installed bz2 support to wincommander
when extracting the file, i get php_manual_de.tar.bz2., wincmd sees this as an erraneous bz2 archive, but it?s really a tar.

The file is named correctly when downloaded via NN or Opera 6.01 fine, but with IE any .bz2 I download extends to ".bz2..bz2". Only workarounds I know are either to rename the downloaded file to .bz2 or strip the ".bz2." from the extracted file.

This bug is definitely NOT YOUR FAULT, but you may add a note on this to the doc downloads page; maybe find out what version of IE on which OSes contain this bug.

Titus Hochgreve

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-07 09:31 UTC] tal@php.net
Most certainly an IE bug, bogusfying.

-Tal
 [2002-07-08 06:05 UTC] goba@php.net
This is a known bug on Win98. If you download any file with an extension unkown to the system (no program connected to the extension), it adds this weird thing to the filename... The solution is client-side: you need to conect a program to the .bz2 extension.
 [2002-07-08 07:34 UTC] derick@php.net
Not a bug in PHP -> bogus
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jun 24 10:01:23 2021 UTC