php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18201 undefined symbol: ts_resource_ex
Submitted: 2002-07-06 17:00 UTC Modified: 2002-07-07 10:58 UTC
From: deadsman at hotmail dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: RedHat 7.2
Private report: No CVE-ID: None
 [2002-07-06 17:00 UTC] deadsman at hotmail dot com
When I try to start apache, It get out this error ...

Syntax error on line 230 of /www/conf/httpd.conf:
Cannot load /www/modules/libphp4.so into server: /www/modules/libphp4.so: undefi
ned symbol: ts_resource_ex

Thx for a response.

Bye

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-06 17:01 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-07-06 18:06 UTC] deadsman at hotmail dot com
Sorry, I forget the system info:

Apache 2.0.36
Php 4.2.1

Apache configuration:
./configure --prefix=/www --enable-module=all

Php configuration:
./configure --with-mysql --with-apxs=/www/bin/apxs
 [2002-07-06 19:06 UTC] sniper@php.net
The correct configure option for Apache2 is --with-apxs2
(notice the number '2' there? :)

btw. If you want to get stable and fully working PHP+Apache,
use Apache 1.3.26. The apache2 support is considered EXPERIMENTAL still..


 [2002-07-07 04:13 UTC] deadsman at hotmail dot com
I just try with --with-apxs2, but the problem is the same...

LOL! With apache ver 1.3.26 I found this problem again! O_o

Bye.
__________
In win2k I haven't problem whit apache2.0.39 and php4.2.1 :O, but in linux yes..
 [2002-07-07 09:21 UTC] sniper@php.net
There's really something wrong with either your build environment and/or the sources. Get fresh sources and use
the correct configure options and it will all be fine.


 [2002-07-07 10:53 UTC] deadsman at hotmail dot com
Great! Yes, there were somethings wrong in my build directory.

Thx sniper! :)
 [2002-07-07 10:58 UTC] sniper@php.net
user error -> bogus.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 10:03:53 2023 UTC