php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18198 RH73 compile error with mysql 4.0
Submitted: 2002-07-06 07:39 UTC Modified: 2002-07-06 09:34 UTC
From: patrick at musehub dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 4CVS-2002-07-06 OS: rh73 w/mysql 4.0
Private report: No CVE-ID: None
 [2002-07-06 07:39 UTC] patrick at musehub dot com
I try to compile the cvs of both php 4.3 and apache 2.0.40,

For the following compile line for php4.3dev alp2

./configure  --with-apxs2=/usr/local/apache/bin/apxs  \
--with-config-file-path=/usr/local/apache/conf  --enable-versioning  \
--with-mysql  --enable-ftp  --enable-bcmath  --disable-debug  \
--enable-memory-limit=yes  --enable-track-vars --enable-save-mode \
--enable-magic-quotes --with-gettext=/usr/bin \
--with-xml --with-imap=/usr/local/imap \
--with-curl=/usr --enable-mbstring --enable-mbstr-enc-trans \
--with-jpeg-dir=/usr --with-png-dir=/usr \
--with-zlib-dir=/usr --with-t1lib=/usr/local \
--with-gd=/usr --with-zlib --enable-gd-imgstrttf \
--enable-gd-native-ttf --with-freetype-dir=/usr \
--with-pdflib=/usr/local --with-openssl=/usr/local/openssl \
--enable-trans-sid --with-cpdflib --with-pgsql --with-ming=/usr  \
--with-bz2 --enable-calendar \
--with-pspell --with-qtdom --enable-tokenizer \



error message:

ext/mysql/libmysql/my_tempnam.lo: In function `my_tempnam':
/root/code/php4-200207060300/ext/mysql/libmysql/my_tempnam.c:103: the use of `tempnam' is dangerous, better use `mkstemp'

It seems that for apache 2.0.39 also reports the same error message.

Best Regards
Patrick Tsang

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-06 08:00 UTC] sander@php.net
In this case, tempnam is used in a safe way. Don't bother.
 [2002-07-06 08:12 UTC] patrick at musehub dot com
But seems that I have to use 'mkstemp' otherwise I can't go on compiling.

Any ideas?

Patrick Tsang
 [2002-07-06 08:51 UTC] sander@php.net
Are you completely sure the compile fails because of _this_ message? AFAIK, this is only a warning, not an error.
Which verion of GCC are you using?
 [2002-07-06 08:58 UTC] patrick at musehub dot com
gcc --version
2.96

All apache 2.0.40, apache 2.0.39 stops compiling.
 [2002-07-06 09:34 UTC] sniper@php.net
http://gcc.gnu.org/gcc-2.96.html

Install GCC 2.95.3 and you have no problems anymore.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 28 18:01:24 2020 UTC