php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18192 Apache Segfaults(11) when transforming XML to HTML
Submitted: 2002-07-05 18:52 UTC Modified: 2002-07-06 04:53 UTC
From: mark at iptower dot nl Assigned:
Status: Not a bug Package: Sablotron XSL
PHP Version: 4.2.1 OS: Linux 2.4.18 kernel
Private report: No CVE-ID: None
 [2002-07-05 18:52 UTC] mark at iptower dot nl
I am going crazy over here :( For several days now, I am trying to use PHP 4.2.1 in combination with Sablotron 0.95 to transform XML into HTML. I applied all patches that are available on the website of Sablotron. (Apache version: 1.3.26, libxml version: 2-2.4.22, expat version: 1.95.3).

I have compiled Apache with the --disable-rule=EXPAT parameter. PHP is compiled with these parameters:

./configure --with-apache=/develop/apache_1.3.26/ --with-mysql=/usr/local/mysql --with-pgsql=/usr/local/
postgres --prefix=/usr/local/php --with-sablot=/usr/local/sablot --with-xslt-sablot=/usr/local/sablot  --with-expat-dir=/usr/local/
expat --with-zlib --with-dom=/usr/local/libxml/ --enable-trans-sid --enable-xslt --enable-sablot-error-descriptive --enable-track-v
ars --enable-safe-mode

Everything compiles fine and apache starts without any error at all. But as soon as I try to transform certain XML pages, apache crashes and writes to the error_log file:

[Sat Jul  6 02:37:45 2002] [notice] child pid 11443 exit signal Segmentation fault (11)
[Sat Jul  6 02:37:46 2002] [notice] child pid 11444 exit signal Segmentation fault (11)

We have compiled the same combination on a Slackware 7 machine, with the same results... :(

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-06 02:18 UTC] sniper@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
 [2002-07-06 04:49 UTC] mark at iptower dot nl
Shame on me... I have backtraced the segfault according to the "manual". It became clear to me at that point (while reading the backtrace) that there was a circulair reference within an object :) (error reporting module causes an error which must be reported with the same error reporting module :)).

So, afterall, no bug is involved in this case.
 [2002-07-06 04:53 UTC] sander@php.net
Not a bug in PHP -> bogus.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 14:01:28 2019 UTC