php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18171 version incompatabilities for module "php4apache2.dll"
Submitted: 2002-07-04 18:58 UTC Modified: 2002-07-04 19:46 UTC
From: vp dot news at retico dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: W2k Prof
Private report: No CVE-ID: None
 [2002-07-04 18:58 UTC] vp dot news at retico dot com
With the security issues in Apache  before v2.0.39, please note:

For Apache 2.0.36, and PHP 4.2.1.
LoadModule php4_module c:/php/sapi/php4apache2.dll
Works

** This will not work for 2.0.39!!!

When starting Apache 2.0.39, it complains about version incompatabilities for module "php4apache2.dll"

The bug tracking indicates this has already been reported and classified as "bogus". I have this problem, and am aware of 3 other unrelated similar findings. Thus I had to revert back to Apache 2.0.36, and continue to worry about the security "hole". So have the other cases.

All in all, its horrible how poor the documentation is for windows Apache users, who would like to implement php with Apache but are left in the dark with outdated/incomplete/unclear documentation.

I have many years experience with php in both windows and linux so I generally find my way through the issues but i'm worried about the majority of the windows users...

If help is needed to test fixes for this problem, I can help.

Thanks beforehand.
Will

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-04 19:46 UTC] sniper@php.net
The problems are fixed in CVS. Grab the latest STABLE snapshot from http://snaps.php.net/win32/

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Aug 13 08:05:44 2022 UTC