php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18153 Wrong entry in php.ini causes problems with query processing
Submitted: 2002-07-03 18:59 UTC Modified: 2002-09-11 11:24 UTC
From: thomasw at wanadoo dot nl Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.2.1 OS: Linux 2.4.18
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: thomasw at wanadoo dot nl
New email:
PHP Version: OS:

 

 [2002-07-03 18:59 UTC] thomasw at wanadoo dot nl
<? echo $blah; ?>
produces nothing when the script is called with ?blah=hello
when this is set in php.ini:

; List of separator(s) used by PHP to parse input URLs into variables.
; Default is "&".
; NOTE: Every character in this directive is considered as separator!
arg_separator.input = ";&"

It does produces something ("hello") when set to this:
; List of separator(s) used by PHP to parse input URLs into variables.
; Default is "&".
; NOTE: Every character in this directive is considered as separator!
arg_separator.input = "&;"

I dont know if this is a problem in the php code or just the ini.. The change made it work fine though :-)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-03 19:06 UTC] sniper@php.net
I can not reproduce this. Try this script instead:

<?php print_r($_GET); ?>


 [2002-09-11 11:24 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jan 24 20:03:33 2022 UTC