php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18107 Error while loading the SAPI module
Submitted: 2002-07-02 07:03 UTC Modified: 2002-07-02 07:10 UTC
From: cedric dot dufour at cogito-ergo-soft dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: Windows XP Pro
Private report: No CVE-ID: None
 [2002-07-02 07:03 UTC] cedric dot dufour at cogito-ergo-soft dot com
When attempting to load the SAPI module under Apache 2.0.39

  LoadModule php4_module "C:/Program Files/PHP4/sapi/php4apache2.dll"

Apache2 service fails to launch.

When running the Apache's configuration test, I get the following message:

Apache.exe: module "c:\php4build\snap\sapi\apache2filt
er\sapi_apache2.c" is not compatible with this version of Apache.
Please contact the vendor for the correct version.

Has anyone any clue how to solve this problem ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-02 07:10 UTC] mfischer@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 17:05:53 2022 UTC