php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18106 mysql_db_query - insert returns wrong status
Submitted: 2002-07-02 04:18 UTC Modified: 2002-07-02 04:19 UTC
From: info at fitnesswelt dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.1.2 OS: Suse Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at fitnesswelt dot com
New email:
PHP Version: OS:

 

 [2002-07-02 04:18 UTC] info at fitnesswelt dot com
At our website we insert some datasets into tables and ask if it was successfull or not in this manner:
$query = "insert into ....";
if (mysql_db_query("my_database",$query) == FALSE){ echo "error save data: " . mysql_error();	
} else {....

But since we have updated to version 4.1.2 - we always get this status although the dataset is saved well.
This behaviour is in all our insert queries, I didn't chek if other kind of SQL-statements have the same behaviour.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-02 04:19 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 11:05:53 2022 UTC