php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18054 cannot get php w imap compiled to start
Submitted: 2002-06-28 15:58 UTC Modified: 2002-09-11 11:30 UTC
Votes:9
Avg. Score:4.3 ± 0.8
Reproduced:8 of 8 (100.0%)
Same Version:0 (0.0%)
Same OS:5 (62.5%)
From: quelrods at mail dot utexas dot edu Assigned:
Status: No Feedback Package: IMAP related
PHP Version: 4.2.1 OS: openbsd 3.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-06-28 15:58 UTC] quelrods at mail dot utexas dot edu
./configure --with-mysql --with-gettext --with-xml --with-ftp --with-apxs=/usr/local/apache/bin/apxs --with-imap --with-kerberos --with-imap-ssl

if i do a --with-map it says i must enable kerberos bc the imap lib and subsquently ssl
removing the imap, kerberos, and imap-ssl resules in a working php module...configs/compiles fine however when i try to even do a httpd -t i get:

/usr/local/apache/bin/httpd -t                        /usr/libexec/ld.so: Undefined symbol "_GSS_C_NT_HOSTBASED_SERVICE" in httpd:/usr/local/lib/libc-client.so.4.0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-28 21:05 UTC] sniper@php.net
Please try that configure line again and check the config.log for the error, why it fails. 

--Jani

 [2002-06-29 00:23 UTC] quelrods at mail dot utexas dot edu
it configures and compiles fine
there are no warnings or errors in config.log

oh found this after the make:
*** Warning: This library needs some functionality provided by -lresolv.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lresolv.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lgssapi_krb5.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lk5crypto.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcom_err.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.

i have kerberos, libresolv, etc. installed and ldconfig'd -R besides if it wasn't find the crypto how would the configure pass?  I guess it's time to hack makefiles ugh
 [2002-06-29 16:30 UTC] quelrods at mail dot utexas dot edu
from debug.log
   15 gcc -o conftest -g -O2  -DMOD_SSL=208110 -DEAPI -DUSE_EXPAT  -R/usr/local/lib -L/u
        sr/local/lib -R/lib -L/lib conftest.c -lintl -lresolv -lm  -lresolv -lgssapi_krb5
        -lkrb5 -lk5crypto -lcom_err 1>&5
     16 ld: -lgssapi_krb5: no match
     17 collect2: ld returned 1 exit status

issue w/ a kerberos library..i tried recompiling imap instead of the openbsd package to disable kerberos to no avail...i don't even want kerberos but bc imap linked it php wants it too..any thoughts on how to get php to match all the libs prop ?
 [2002-07-02 23:56 UTC] sniper@php.net
Try this snapshot:

http://snaps.php.net/php4-latest.tar.gz

I has libtool 1.4.2 which is claimed to fix some openbsd issues..

 [2002-09-11 11:30 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 05:01:23 2020 UTC