php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17877 installing PHP and not able to start iplanet server
Submitted: 2002-06-20 12:34 UTC Modified: 2002-06-20 14:21 UTC
From: dooms at sun dot com Assigned:
Status: Not a bug Package: iPlanet related
PHP Version: 4.2.1 OS: solaris 8 Generic_108528-14
Private report: No CVE-ID: None
 [2002-06-20 12:34 UTC] dooms at sun dot com
installed mysql-3.23.51 nad php-4.2.1 with                 iPlanet-WebServer-Enterprise/6.0SP2 B11/13/2001
on solaris 8. Followed the process for Servers-Netscape and iPlanet and now get the following errors when tring to
start the iplanet server. 

20/Jun/2002:09:46:10] config (10920):                      for host 0.0.0.0 trying to GET /, func_exec reports: cannot find function named php4_auth_trans 

[20/Jun/2002:09:46:10] config (10920):                       func_exec reports: cannot find function named php4_init 

[20/Jun/2002:09:46:10] failure (10920):                      Late initialization failed: Error running init function(late) php4_init: unknown error 

modified:

 /configure --with-mysql=/usr/local/mysql --with-nsapi=/www/iplanet/servers --enable-track-vars --enable-libgcc

add to the obj.conf file

<Object name="default">
AuthTrans fn=php4_auth_trans
.
.
.
.#NOTE 
.#This next line should happen after 
.#all 'ObjectType' and before all 'AddLog' lines
 Service fn="php4_execute"
 type="magnus-internal/x-httpd-php"
.
.
.
</Object>

<Object name="x-httpd-php"> 
 ObjectType fn="force-type"
 type="magnus-internal/x-httpd-php" 
 Service fn=php4_execute 
</Object>

add to the magnus.conf file

Init fn="load-modules"
shlib="/your/path/from/root/libphp4.so"
                    funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
Init fn="php4_init" LateInit="yes"

add to the mime.type file

type=magnus-internal/x-httpd-php        exts=php,php3,php4,phtml

Thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-20 14:07 UTC] dooms at sun dot com
please close bug. was able to get server back up.
issue was due to the magnus.conf. I added the new php info as one line not two.

Thanks.
 [2002-06-20 14:21 UTC] sander@php.net
Closing on user request.
 [2002-12-21 07:10 UTC] sghanukot at yahoo dot com
Dear Friends

I had similar problems in installing PHP in iPlanet. But i got rid of them. Here is the complete solution. 

After sucessfully installing PHP (follow any PHP installation docs), install iPlanet.

My Machine details

----------------------------------------

Platform: windows 2000 client

PHP version: php4.2.3

iPlanet version: Sun(TM)ONE Web Server Enterprise Edition 6.0 Service Pack 4 (formerlyiPlanet(TM) Web Server Enterprise Edition 6.0 Service Pack 4)

Jsdk Version: jdk1.3.1

i have made the following changes to the default local virtual server of your iPlanet installation (usually i will be with your machine name on windows, i dont know on other platfoms) conf files (each statement is in a single line).



magnus.conf

---------------------

Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="c:/php423/sapi/php4nsapi.dll"   (this whole statement is in a single line)
Init fn="php4_init" LateInit="yes" errorString="Failed to initialise PHP!" (this whole statement is in a single line)




in obj.conf

----------------------

in <Object name=default> section add this line before addlog after all objecttype

Service fn="php4_execute" type="magnus-internal/x-httpd-php"  (single line)

(add the below statements at the end of the file)

<Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute
</Object>


write some sample test php file and place in docs directory of your iplanet. 
open browser and try this 

http://127.0.0.1/test.php (or what ever be your php file name)



best wishes
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 22 09:01:27 2019 UTC