php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17849 ISAPI-version fails to load on 2.0.39
Submitted: 2002-06-19 14:23 UTC Modified: 2002-06-19 14:39 UTC
From: Kristian dot Bergmann at nvg dot org Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: Windows XP
Private report: No CVE-ID: None
 [2002-06-19 14:23 UTC] Kristian dot Bergmann at nvg dot org
When trying to load the sapi\php4apache2.dll under Apache 2.0.39, I recieve the following error:

Apache.exe -t
Apache.exe: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not compatible with this version of Apache.
Please contact the vendor for the correct version.

The CGI-version runs fine, while the .36 runs the SAPI just fine, indicating that the changes the Apache-crew made to sapi is incompatible with this dll.

Furthermore, the PHP-install (for Apache 1.3.x) says to use
AddModule mod_php4.c. This failed under .36, so I would also suggest you include a segment on Apache2.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-19 14:25 UTC] derick@php.net
I guess reading is quite hard for you guys.
 [2002-06-19 14:35 UTC] Kristian dot Bergmann at nvg dot org
Obviously. Care to elaborate or do you get a certain kick out of that Oracleish attitude? :p
 [2002-06-19 14:39 UTC] mfischer@php.net
He was refering to http://bugs.php.net/report.php:

"PLEASE DO NOT REPORT BUGS ABOUT PHP NOT WORKING WITH APACHE 2.0.39!!! THIS IS FIXED IN CVS AND YOU CAN TRY THE LATEST SNAPSHOT FROM HERE"

Where "HERE" -> http://snaps.php.net/php4-latest.tar.bz2
 [2002-06-19 14:43 UTC] Kristian dot Bergmann at nvg dot org
A thousand pardons.
 [2002-06-19 14:49 UTC] Kristian dot Bergmann at nvg dot org
Actually, that notice wasn't there when I initially reported the bug, so no need to yell at me. ;)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 14:05:55 2022 UTC