php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17847 object-methods for pcntl_signal
Submitted: 2002-06-19 14:12 UTC Modified: 2002-09-26 12:12 UTC
From: marcel at beerta dot de Assigned:
Status: Closed Package: *Extensibility Functions
PHP Version: 4.2.1 OS: Linux
Private report: No CVE-ID: None
 [2002-06-19 14:12 UTC] marcel at beerta dot de
There seems to be no possible way to pass an object-method to the pcntl_signal function. Passing an array with $object,'method' gives me an e_warning, and accessing the object with global inside a signal-handler won't work either. It would be cool if anyone out there implemented this.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-19 18:25 UTC] alan_k@php.net
Duplicate of #15125

The patch attached to to #15125 doesnt work, and I havent had time to look at it again.. it's on my todo list...

regards
alan
 [2002-09-26 12:12 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 21:01:23 2020 UTC