php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17845 Apache 2.0.39 will not work with php until this change is made
Submitted: 2002-06-19 13:24 UTC Modified: 2002-06-19 13:25 UTC
From: webmaster at jkcc dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: WinNt
Private report: No CVE-ID: None
 [2002-06-19 13:24 UTC] webmaster at jkcc dot com
Tonight apache released 2.0.39-dev which has some important updates for modrewrite & ssl amoung other things... 

for whatever reason there is a problem compiling with apache2filter && sapi / apache 2 

In order to fix it, make a quick hack to php_functions.c on ln 93 by removing the IF statement completely.  

Code Removed: 
#if !MODULE_MAGIC_AT_LEAST(20020506,0) 
ADD_STRING(boundary); 
#endif 

Initial Error: 
Missing binary operator before '!' .... 

Again, this was all done after upgrading apache2 and it now works on my server. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-19 13:25 UTC] derick@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 03:03:33 2021 UTC