php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17832 Apache cannot start
Submitted: 2002-06-19 08:07 UTC Modified: 2002-06-19 08:14 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: vital at radio dot odessa dot ua Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: Windows 2000 Server
Private report: No CVE-ID: None
 [2002-06-19 08:07 UTC] vital at radio dot odessa dot ua
I have Apache 2.0.36 with PHP 4.2.1 installed as module.
Apache's httpd.conf contains row:
LoadModule php4_module c:/progra~1/php/sapi/php4apache2.dll

All works fine.
Today I've try to upgrade Apache to version 2.0.39 released on May, 18. Apacehe does not start and reports about incorrect version of files in directory c:\php4build...

That directory does not exist at all, so an error is in php4apache2.dll

If I try to comment line shown above in httpd.conf, apache starts without any warnings, but without PHP4 too...

So I've downgrade Apache back...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-19 08:10 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 [2002-06-19 08:14 UTC] sander@php.net
See #17826.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 04:05:52 2022 UTC