php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17829 undefined symbol: __dn_expand
Submitted: 2002-06-19 00:53 UTC Modified: 2002-06-19 01:29 UTC
From: skraj at telocity dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.2.1 OS: Debian Linux 2.2.20
Private report: No CVE-ID: None
 [2002-06-19 00:53 UTC] skraj at telocity dot com
I compiled and installed php using the following:

$ ./configure --prefix=/usr/local/php --with-apxs=/usr/local/apache/bin/apxs
$ make
$ make install

Everthing went fine. When I started Apache I got the
following error message:

Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: __dn_expand
bin/apachectl start: httpd could not be started

I tried several suggestions from newsgroups to recompile
and reinstall php; however, I keep getting the same error
message.

I am using apache 1.3.24.

Help please!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-19 01:27 UTC] imajes@php.net
This is a known issue. Please use cvs if you wish to use apache2.
 [2002-06-19 01:29 UTC] imajes@php.net
sigh. wrong one.

What i meant to say is that you will need to recompile your php version. I can assure you that it should work, as I did it this morning without a problem.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 18:03:50 2022 UTC