php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #17819 Add optional parameter to gethostbyaddr() and gethostbyip() to set DNS server
Submitted: 2002-06-18 13:39 UTC Modified: 2021-05-26 12:30 UTC
Votes:8
Avg. Score:3.8 ± 0.8
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: rparish at digitalwebzone dot com Assigned:
Status: Wont fix Package: Network related
PHP Version: * OS: *
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-06-18 13:39 UTC] rparish at digitalwebzone dot com
 Can we get the function gethostbyaddr or 
gethostbyip to accept a second value. 
that second value would be that of what DNS server 
to query to get the information. 
If second value is NULL, then use the systems 
resolv library. 
 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-18 11:01 UTC] moriyoshi@php.net
This feature request seems the same as bug #14246

 [2003-01-18 11:23 UTC] sniper@php.net
Let's leave this open and close the other one. (this one is more clear about what is requested)

 [2011-01-01 00:57 UTC] jani@php.net
-Summary: gethostbyaddr +Summary: Add optional parameter to gethostbyaddr() and gethostbyip() to set DNS server -Package: Feature/Change Request +Package: Network related -Operating System: RedHat Linux 7.2 +Operating System: * -PHP Version: 4.1.2 +PHP Version: *
 [2017-10-23 01:05 UTC] kalle@php.net
-Status: Open +Status: Analyzed
 [2021-05-26 12:30 UTC] krakjoe@php.net
-Status: Analyzed +Status: Wont fix
 [2021-05-26 12:30 UTC] krakjoe@php.net
While PHP relies on libc implementations of these functions, it's not practical to consider this as there's no reasonably portable way to do it.

Since PHP has been relying on libc implementations of these functions forever, there's no reason to expect this to change.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Jun 23 21:01:23 2021 UTC