php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17818 Maximum Execution Time exceeded
Submitted: 2002-06-18 12:18 UTC Modified: 2002-09-11 11:20 UTC
Votes:15
Avg. Score:4.3 ± 1.1
Reproduced:10 of 10 (100.0%)
Same Version:1 (10.0%)
Same OS:1 (10.0%)
From: clay at incogen dot com Assigned:
Status: No Feedback Package: PHP options/info functions
PHP Version: 4.2.1 OS: SunOS jabba 5.7 Generic_106541-1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-06-18 12:18 UTC] clay at incogen dot com
I have tried to set the max_execution time using both the php.ini and the set_time_limit function.  Setting these values to > 30 or to 0 which is supposed to be unlimited has produced the same error message

Fatal error Maximum Execution Time 30 seconds exceeded

here is my phpInfo

SystemSunOS jabba 5.7 Generic_106541-18 sun4u sparc SUNW,Ultra-4 Build DateJun 17 2002 10:54:33 Configure Command './configure' '--prefix=/raid5/geneport/php' '--with-apxs=/raid5/geneport/aldev/apache_1/bin/apxs' '--without-mysql' '--with-oci8' '--enable-track-vars' '--enable-gd-native-ttf' '--with-gd' '--with-freetype-dir=/usr/local' '--with-png-dir=/usr/local' '--with-zlib=/usr/local' '--with-config-file-path=/raid5/geneport/php/conf' Server APIApache Virtual Directory Supportdisabled Configuration File (php.ini) Path/raid5/geneport/php/conf/php.ini Debug Buildno Thread Safetydisabled

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-18 12:35 UTC] sander@php.net
Does phpinfo() show the appropriate values? Restart your webserver if necessary.
Does it take 30 seconds to come up with that message or does it show that at once?
 [2002-06-18 12:38 UTC] clay at incogen dot com
The phpInfo shows the appropriate value, 

The script takes about a minute ( or a few minutes ) to run, then shows the error.

I have restarted apache, I have stopped and started apache.
 [2002-06-18 12:44 UTC] clay at incogen dot com
I'm using apache 1.34
 [2002-06-18 17:38 UTC] sniper@php.net
Please add a short example script here which causes this problem.

 [2002-06-18 17:44 UTC] clay at incogen dot com
Don't we all wish it were that easy.  The script that is causing this problem is pulling large datasets from Oracle, calling all sorts of libraries, its an insane machine of scripts.  I think this (the OCI usage)is probably were the problem originates.  However, I am concerned that the  error message does not reflect the time out value.  Is the error message hard-coded to 30 seconds?  phpInfo() knows the max execution time value that I have set, so why doesn't the error message?
 [2002-06-18 18:05 UTC] sniper@php.net
So this happens ONLY with that one script?

 [2002-09-11 11:20 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-11-21 03:43 UTC] kalpesh dot c at globalwebwise dot com
I have also accure this type of error.
"Fatal error Maximum Execution Time 30 seconds exceeded"
if anybody have to solucation for that so please quick answer send me.
 [2004-07-23 09:56 UTC] fsiaw at triangleauto dot com dot sg
Have the same error when I test the DOM.  Please help

here is the script I was testing with

<?php 
$domainObject = new COM("WinNT://Domain"); 
while ($obj = $domainObject->Next()) { 
   echo $obj->Name . "<br />"; 
} 
?>
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 16 07:01:29 2024 UTC