php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17777 seems a path is hardcoded into configure
Submitted: 2002-06-15 18:46 UTC Modified: 2002-06-15 19:55 UTC
From: mike at takiweb dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: freebsd 4.5 stable
Private report: No CVE-ID: None
 [2002-06-15 18:46 UTC] mike at takiweb dot com
when trying to install with ./configure --with-mysql --with-apxs=/usr/home/mike/www/bin/apxs

i get the following error which says a path /x1/home/aaron/httpd-2.0.35/bindist/build/config_vars.mk doesnt exist: 


Sorry, I was not able to successfully run APXS.  Possible reasons:

1.  Perl is not installed;
2.  Apache was not compiled with DSO support (--enable-module=so);
3.  'apxs' is not in your path.  Try to use --with-apxs=/path/to/apxs
The output of /usr/home/mike/www/bin/apxs follows
cannot open /x1/home/aaron/httpd-2.0.35/bindist/build/config_vars.mk: No such file or directory at /usr/home/mike/www/bin/apxs line 248.
configure: error: Aborting

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-15 19:55 UTC] sniper@php.net
First of all, you should get the Apache 2.0.36.
Second, get latest CVS of PHP to be able to get a version
that actually works somehow with it.
Third, the configure option is --with-apsx2

Not a bug. Also I'd suggest you use Apache 1.3.24 since
apache2 is really not usable at all on freebsd.
(read their docs for more info)

PHP 4.2.1 also works very nicely with apache 1.3.24..

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 08:05:53 2022 UTC