php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17765 MSSQL stored procedure related functions do not exist
Submitted: 2002-06-14 14:24 UTC Modified: 2002-06-15 20:03 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: xavier at nextdimensioninc dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.1.2 OS: Solaris 2.8
Private report: No CVE-ID: None
 [2002-06-14 14:24 UTC] xavier at nextdimensioninc dot com
http://www.php.net/manual/en/function.mssql-execute.php

This page defines mssql_execute(); as available since version 4.1.0

I am using version 4.1.2 and compiled PHP with FreeTDS, not as a DSO module but in the apache binary.

All the mssql functions are working just fine (mssql_query, mssql_connect, mssql_num_rows, etc...)

but mssql_init and mssql_execute report the following error:

Fatal error: Call to undefined function: mssql_execute() in /usr/local/infonext/reports.php on line 55.


This is very unfortunate as I compiled PHP in a very painful way on a production machine.

Is there a workaround ?
Has this problem been fixed yet ?
the documentation seems to be inaccurate since it states:
(PHP 4 >= 4.1.0)



Thanks.
Xavier Spriet.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-14 15:22 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


Just wondering..are the other functions available?
And how did you compile PHP ? 
 [2002-06-14 15:32 UTC] xavier at nextdimensioninc dot com
Yes, as mentionned above, every other MSSQL function is available and working, this includes mssql_query, mssql_result, mssql_connect, mssql_num_rows and more.

Only the functions related to stored procedure initialization, binding and execution are simply not present in PHP 4.1.2 on Unix.

After additional reading on the mssql_execute mannual page on the main documentation, a user commented that the source code of PHP for these functions are aliases of the similar sybase functions, and PHP will behave differently on Unix than on Windows with these functions.

PHP was compiled in the following way:

./configure --with-apache=/usr/local/download/apache-1.3.25/ --with-sybase=/usr/local/freetds --enable-trans-sid

Apache was compiled with:

./configure --enable-module=ssl --activate-module=src/modules/php4/libphp4.la

This is using PHP 4.1.2 and apache 1.3.24 on a solaris 2.8 netra box.

I'm not sure what additional information you require...
the problem, to be brief is simply that all stored procedure related functions for the mssql extension on unix do not exist on php4.1.2.
 [2002-06-15 20:03 UTC] sniper@php.net
This mssql_execute() function is only available with the mssql extension which is available only on win32.

Check the sybase documentation:

http://www.php.net/manual/en/ref.sybase.php

(some of these seem to have mssql_* aliases)

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 22 00:01:27 2024 UTC