php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17705 str_pad optional parameters not optional
Submitted: 2002-06-11 12:13 UTC Modified: 2002-07-07 13:46 UTC
From: dvernet at kingstonsf dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 4.0CVS-2002-06-11 OS: Win2000
Private report: No CVE-ID: None
 [2002-06-11 12:13 UTC] dvernet at kingstonsf dot com
Win2K, PHP4.06, Apache

Omitting the optional [pad_string] and [pad_type] params for str_pad() will not produce default behaviour ie, rather nothing is done to the string at all.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-11 19:21 UTC] sniper@php.net
Can't reproduce. Please add a short but complete script here
which can be used in reproducing this bug.

 [2002-07-07 13:06 UTC] derick@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-07-07 13:46 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Oct 14 08:01:26 2019 UTC