php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17648 syslog inserts random characters into log files
Submitted: 2002-06-07 16:33 UTC Modified: 2002-07-31 18:11 UTC
From: swinghammer at starbak dot net Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.1.2 OS: Linux
Private report: No CVE-ID:
 [2002-06-07 16:33 UTC] swinghammer at starbak dot net
Here is an example of some of the output from our log files.  The syslog function was called with:

define_syslog_variables ();
openlog("name",LOG_ODELAY,LOG_LOCAL3);

preceding it, closelog was never called.  If this is the cause, then the documentation should be updated to reflect this requirement.  Here is an example of what is in the logs:

 () at Jun  5 12:51:25,
000; text-decoration: underline} at Jun  5 14:09:12,
^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^ at Jun  5 14:09:33,
ormat: () at Jun  5 14:09:12,

Jun  5 14:09:33 h118
^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^B^D^D^D^D^D^D^D^D:

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-31 18:11 UTC] kalowsky@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Unable to reproduce on FreeBSD with CVS... do please try a more recent release.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 00:02:04 2014 UTC