php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17523 Mail_mime::get() must be called before Mail_mime::headers()
Submitted: 2002-05-30 06:35 UTC Modified: 2002-05-30 12:47 UTC
From: gaudenz at soziologie dot ch Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.1.2 OS: Linux SPARC
Private report: No CVE-ID: None
 [2002-05-30 06:35 UTC] gaudenz at soziologie dot ch
If you compose a multipart mime message with Mail_mime then you have to call the method $mime->get() before $mime->headers($additional_hdrs). If you don't do so, the headers are not correct (missing line Conten-Type:).

This should be fixed or at least documented.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-30 09:20 UTC] richard@php.net
Not a bug. Feel free to document if you so desire.
 [2002-05-30 12:47 UTC] mj@php.net
For the notes: I've placed a comment about this in the manual. The changes should be online within the next days.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC