php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17511 PATH_TRANSLATED variable incorrectly set since PHP 4.0.5
Submitted: 2002-05-29 13:41 UTC Modified: 2002-07-07 12:54 UTC
From: schaefer at jobpilot dot com Assigned:
Status: Not a bug Package: Variables related
PHP Version: 4.1.2 OS: Linux 2.2/SuSE 6.4
Private report: No CVE-ID: None
 [2002-05-29 13:41 UTC] schaefer at jobpilot dot com
Hi,

I had to generate a new bug report, since a bug in your bug tracking system prevented me from editing the original one.

between version 4.0.4 and 4.0.5 the setting of the PATH_TRANSLATED variable changed. In version
4.0.4, the following URL

http://www1.jobpilot.de/test.phtml/bla/fasel

resulted in the following PATH_TRANSLATED value:

/JobsAdverts/OnlineServer/web/de/test.phtml

(which is the correct script file name).

ever since 4.0.5, the same URL results in the following value:

/JobsAdverts/OnlineServer/web/de/bla/fasel

which does not look right. According to the documentation, PATH_TRANSLATED is the "Filesystem- (not document root-) based path to the current script, after the server has done any virtual-to-real mapping. "

BTW. the documentation should make it clear what is the difference between PATH_TRANSLATED and SCRIPT_FILENAME - from to the current explanation, I don't understand it.

BTW we are using Apache 1.3.23.

Best Regards,

Arno Schaefer

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-05 11:38 UTC] snowgod at snowgod dot org
I could be wrong, but I would think that it is the job of Apache to set that variable. The CGI documentation I've read says that the job of setting enviromental variables like that when executing a cgi is the responsiblity of the web server.
 [2002-07-07 12:54 UTC] derick@php.net
Not a PHP problem, but an Apache one.

Derick
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Feb 24 04:01:28 2024 UTC