php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17452 register_globals not being read from php.ini
Submitted: 2002-05-27 07:31 UTC Modified: 2002-05-27 08:35 UTC
From: gijs at spill dot nl Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.2.1 OS: Redhat 7.0
Private report: No CVE-ID: None
 [2002-05-27 07:31 UTC] gijs at spill dot nl
While updating php.ini to set register_globals = On and after restarten apache(1.3.24) php still shows in phpinfo() that register_globals = Off. 

Is there a possibility register_globals  was hard coded in de php source?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-27 07:51 UTC] gijs at spill dot nl
I don;t know why you guys do this but now the default location of php.ini is /usr/local/lib. It first was /etc.

Why did you change this? Could you not put this in de changlog????
 [2002-05-27 08:00 UTC] derick@php.net
AFAIk it did never default to /etc .
ANyway, not a bug -> bogus
 [2002-05-27 08:35 UTC] mfischer@php.net
PHP never defaultet to /etc but to <install-dir/lib . Linux distribution tend to change this do /etc . If you've used a native package in the first and later compiled your own version, they're different then of course.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 20:03:35 2022 UTC