php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17442 Wrong day of week in some days
Submitted: 2002-05-26 16:53 UTC Modified: 2002-05-26 17:04 UTC
From: alex at aspyre dot ro Assigned:
Status: Not a bug Package: Calendar related
PHP Version: 4.2.0 OS: Win 9x
Private report: No CVE-ID: None
 [2002-05-26 16:53 UTC] alex at aspyre dot ro
$bug1 = date("D",mktime (0,0,0,3,27,2032));
echo($bug1."<br>");
$bug2 = date("D",mktime (0,0,0,3,28,2032));
echo($bug2."<br>");
if ($bug1==$bug2) {echo("BUG!");}

i think it's enough. :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-26 17:02 UTC] rasmus@php.net
Works just fine on Linux.  Probably a Win9x problem.
 [2002-05-26 17:04 UTC] derick@php.net
Most likely related to Daylight savings and some bug in Windows. I could not reproduce this on Linux/FreeBSD.
You might have better luck with gmmktime() or a time like noon.

Feel free to reopen if you think this is a PHP issue instead.

Derick
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Aug 11 04:01:26 2020 UTC