php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17366 Passing Variables between scripts
Submitted: 2002-05-22 13:45 UTC Modified: 2002-05-22 13:53 UTC
From: jeremefrancis at sympatico dot ca Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: Win 2000 Professional
Private report: No CVE-ID: None
 [2002-05-22 13:45 UTC] jeremefrancis at sympatico dot ca
When I run the phpinfo.php script, the script works and my browser displays all the information about settings and etc.  It seems like scripts are being run properly but they are not.

If I run the following script from my apache 2 server,  

<?php

print "&name=$name";
print "&lname=$lname";

?>

I get this output in my internet explorer 5 browser window,

&name=&lname

which is the correct output, but if I try to update the variables via the address bar in my browser using this syntax, 

http://localhost/test2.php?name=Joe&lname=Blow

nothing happens, but if I do the exact same thing on my ISP server, the output in the browser window looks like this,

&name=Joe&lname=Blow

And because of this problem I am unable to send variables to other scripts, and the reason I am using PHP is so I can use it in combination with Flash, but I need to be able to send variables from flash to php scripts.  I know I can just do everything on my ISP server but I like to do things on my home computer and not have to upload the files every time I make a change to them. All I am wondering is if there is a certain way Apache 2 or PHP4 has to be configured so that I can send variables between scripts, I have been through all the configuring of the Apaches http.conf file, and I am sure it is right, oh yeah one more thing, my PHP Sever API setting is set to CGI and not to a module, could that be the problem?

Thanks, hope someone could let me know if they have any ideas

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-22 13:53 UTC] derick@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Dec 04 08:03:43 2022 UTC