php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17336 sybase_query fails connecting to a sybase Application Server
Submitted: 2002-05-21 11:41 UTC Modified: 2002-10-10 07:30 UTC
From: mt at ciao dot com Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.1.2 OS: Linux 2.4.17 RedHat 7.2
Private report: No CVE-ID: None
 [2002-05-21 11:41 UTC] mt at ciao dot com
The Problem is with Sybase's "Jaguar CTS component transaction server".
On our application we use it to store session data between serveral web-servers. It's running a simple java-application.

Yesterday i upgraded to 4.2.1 on a test Server. Everything worked fine on 4.1.2.

Code example:
$server = sybase_connect(SERVER,USER,PASS);
sybase_query("exec PhpSession.Manager_de.setSessionData '0146119b4fb52b5e408243a37c118720cb','TEST'",$server);
$query  = sybase_query("exec PhpSession.Manager_de.getSessionData '0146119b4fb52b5e408243a37c118720cb'",$server);
if(!$query)     echo "QUERY FAILED";

You see that our Application is very easy: Just set or get Session-Data. This Code Sample works on all Live-Servers and on the Test Server running 4.1.2. I tried both: connect and pconnect, but 4.2.1 doesn't work. It even doesn't matter which Query i use, they all fail, without Error-Message.

Furthermore, the normal sybase DB-Connections are working without Problems on 4.2.1. It's just this Application-Server connection which fails.

I use the Sybase client 11.9.2 and Apache 1.3.24 (I tried 1.3.23, too).

Thx ...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-09 22:16 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-10-10 07:30 UTC] mt at ciao dot com
new version works fine ...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 23 07:01:23 2021 UTC