php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17259 Makefiles assume bash
Submitted: 2002-05-15 14:39 UTC Modified: 2002-05-30 12:42 UTC
From: dward at maidencreek dot com Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.2.1 OS: Solaris 2.7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dward at maidencreek dot com
New email:
PHP Version: OS:

 

 [2002-05-15 14:39 UTC] dward at maidencreek dot com
The problem is actually in the CVS tree, but I cannot select that as the version for this bug.

It seems that the Makefile assumes that the /bin/sh is really bash for install-pear-installer and install-pear-packages which use bash-specific methods (${descfile%.xml} and ${tmp#*-}) of modifying the variables instead of using sed or something else to do it.

Also note that if the directory path has a - in it then the bash variable modification methods do not work correctly either.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-30 03:59 UTC] mj@php.net
This should have been fixed in CVS. Please try the latest CVS version (http://cvs.php.net/co.php/php4/pear/Makefile.frag) and report, if the problem persists.
 [2002-05-30 12:42 UTC] dward at maidencreek dot com
The problem seems to have been corrected.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 30 08:01:24 2021 UTC