php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17253 DB2 access returns no data under PHP 4.2.x
Submitted: 2002-05-15 12:15 UTC Modified: 2002-05-15 13:55 UTC
From: dpiper at stens dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.2.1 OS: Linux, Debian 2.2
Private report: No CVE-ID:
 [2002-05-15 12:15 UTC] dpiper at stens dot com
Resubmitted from bug #16827 because the stupid form won't let me update it. Can you try actually LOOKING at it instead of just telling me its bogus??


I have noticed that all the DB2 (v7.1) accessing code (via the unified
   ODBC functions) fails to be able to gather results under PHP4.2.1.

   PHP is not crashing, and script execution continues past the points of
   failure, and no error messages are displayed or logged. It appears that
   there is just no data coming back from the odbc_do() function, although
   the return code of odbc_fetch_into() is greather than zero.

   PHP configure line: 

   --with-apache=../apache --enable-trans-sid --with-zlib
   --with-mysql=/usr/local/ --with-ibm-db2=/usr/IBMdb2/V7.1/ --with-ldap
   --with-mcrypt --with-imap --with-gd=/usr/ --with-png-dir=/usr/
   --with-jpeg-dir=/usr/

   Yes, I know there's a lot of stuff compiled in, but I need and use it
   all :)

   I have done a clean build every time for my setup, and the results are
   the same with PHP 4.2.1.

   PHP 4.1.2 does NOT exhibit this problem, using the same compile time
   options as above - and running on the exact same pages on the same
   machine, even a recompile with PHP4.1.2 yields a fully working system.

   Thanks,

   Derek

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-15 12:32 UTC] rasmus@php.net
Nowhere near enough information to do anything with this report.  Provide a 3-line script that doesn't do what you expect it to.
 [2002-05-15 13:55 UTC] kalowsky@php.net
odbc_fetch_into behavior changed in 4.2.X, and it looks like from the sample you sent me via email this is your problem.  If it's untrue, please re-open the bug.  

Getting upset that we aren' "LOOKING" at the bug won't help though.  I did look at the bug, and marked it appropriately. 
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 02:02:10 2014 UTC