php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17233 PHP 4.2.x apache2filter does not recognize -dev versions
Submitted: 2002-05-14 21:52 UTC Modified: 2002-05-17 04:07 UTC
From: daleg at elemental dot org Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: Solaris
Private report: No CVE-ID: None
 [2002-05-14 21:52 UTC] daleg at elemental dot org
sapi/apache2filter/config.m4 fails to recognize Apache 2.x.x-dev (CVS) version strings and thus the test for Apache version gt 2.0.0 fails.

Attached is a patch to compensate for "-dev" being in the version string.

*** config.m4.orig      Tue May 14 21:44:07 2002
--- config.m4   Tue May 14 21:42:52 2002
***************
*** 34,40 ****
    APXS_HTTPD=`$APXS -q SBINDIR`/`$APXS -q TARGET`

    # Test that we're trying to configure with apache 2.x
!   APACHE_VERSION=`$APXS_HTTPD -v | head -1 | cut -f3 -d' ' | cut -f2 -d'/' | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
    if test "$APACHE_VERSION" -le 2000000; then
      AC_MSG_ERROR([Use --with-apxs with Apache 1.3.x!])
    elif test "$APACHE_VERSION" -lt 2000035; then
--- 34,40 ----
    APXS_HTTPD=`$APXS -q SBINDIR`/`$APXS -q TARGET`

    # Test that we're trying to configure with apache 2.x
!   APACHE_VERSION=`$APXS_HTTPD -v | head -1 | cut -f3 -d' ' | cut -f2 -d'/' | cut -f1 -d'-' | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
    if test "$APACHE_VERSION" -le 2000000; then
      AC_MSG_ERROR([Use --with-apxs with Apache 1.3.x!])
    elif test "$APACHE_VERSION" -lt 2000035; then

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-17 04:07 UTC] jwoolley@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.

Huh, what awk do you have?  gawk doesn't seem to care about the -dev (I get 2000037 as expected, even with the -dev).  Oh well, the patch doesn't hurt anything either, so I went ahead an applied it.  Done for apache 1.3 as well, btw.  Thanks!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 18 14:03:36 2021 UTC