php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17192 DLL not valid
Submitted: 2002-05-13 19:15 UTC Modified: 2002-05-14 20:26 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: hubweb at hotmail dot com Assigned: edink (profile)
Status: Closed Package: GD related
PHP Version: 4.2.1 OS: Windows 2002
Private report: No CVE-ID: None
 [2002-05-13 19:15 UTC] hubweb at hotmail dot com
Today I installed PHP 4.2.1 and did everything I had to do... copy DLLs to Winnt\System32, configure Apache, etc. When I started Apache, I got an error concerning php_gd2.dll : it can't be loaded. I think there is an error of compilation in Win32 binaries of PHP 4.2.1.

Thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-13 19:32 UTC] phpbugs at ski-info-online dot com
I've got the same problems (OS = WinXP) trying to load the curl and sockets modules. Apache reports the PHP API compile date of 20010901(!) but the modules as 20020429. 

Also, where are the missing modules (imap, ldap, etc)?
 [2002-05-14 00:44 UTC] mfischer@php.net
Missing modules -> assigning to Edin
 [2002-05-14 02:10 UTC] edink@php.net
I can confirm that php_gd2.dll seem not to be functional. But problems reported by phpbugs@ski-info-online.com are probably due to misconfiguration on his part. Plus php_imap.dll, php_ldap.dll are both included in the zip file.

 [2002-05-14 03:08 UTC] edink@php.net
Could you please try php_gd2.dll that I just uploaded to http://ftp.proventum.net/pub/php/win32/php_gd2.zip

 [2002-05-14 04:47 UTC] phpbugs at ski-info-online dot com
Hi,

Apologies regarding the missing dll's. That was my blindness (looking in my 4.2.0 folder). I've now removed all previous installations (even though the php.ini and httpd.conf were pointing to the correct locations). 

However, I cannot get the curl, imap, or ldap  modules to load from my extensions folder (d:\php-4.2.1-Win32\extensions). I keep getting the message I posted in my previous post.

Thanks
 [2002-05-14 09:18 UTC] edink@php.net
Are you sure you have copied php4ts.dll and dlls\*.dll to your windows system folder. 
 [2002-05-14 11:05 UTC] hubweb at hotmail dot com
I tried http://ftp.proventum.net/pub/php/win32/php_gd2.zip

It works fine, but I have problems with ImageTtfText(). It says me : " Warning: Could not find/open font in ... on line ... " !
 [2002-05-14 20:26 UTC] edink@php.net
You need to set the path to you fonts dir. Here is a fully working example:

<?php
putenv('GDFONTPATH=c:\winnt\fonts');
header ("Content-type: image/jpeg");
$im = imagecreate (400, 30);
$black = imagecolorallocate ($im, 0, 0, 0);
$white = imagecolorallocate ($im, 255, 255, 255);
imagettftext ($im, 20, 0, 10, 20, $white, 'arial', "Testing...Omega: &#937;");
imagejpeg ($im);
imagedestroy ($im);
?>

 [2003-11-25 20:16 UTC] s0urce_code at net dot hr
I know I need to set the path to the fonts dir. However, this is a nuisance. Plus, it IS a bug that font isn't read correctly (or at all) from the directory specified. What about when I'll be uploading my site to some server on the web? I'd have to contact the host to ask them where they have fonts installed? That's a bit awkward, no?

s0urce
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 03:01:26 2019 UTC