php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17170 unhandled exception processing the ISAPI
Submitted: 2002-05-12 22:23 UTC Modified: 2002-05-13 02:44 UTC
From: keithauyeung at proactive dot com dot hk Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.2.0 OS: WIN2000 server (SP2)
Private report: No CVE-ID: None
 [2002-05-12 22:23 UTC] keithauyeung at proactive dot com dot hk
Application use: ODBC, sessions, oci8, oracle.

I tried PHP ISAPI version (4.2.0)
I am using generic client socket(i.e. fsockopen()) to communicate with a server. It work fine at the begin, but I found that if the server suddenly shutdown. The follow error
occur:

The HTTP server encountered an unhandled exception while processing the ISAPI Application '
php4ts!zend_strndup + 0x2B
 + 0xA05E5983

and I have to reboot the system because IIS won't work!!!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-13 02:44 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-06-10 09:07 UTC] fabien dot dehopre at itn dot skynet dot be
I have the same error!

But the EventLog Viewer doesn't give more details
about this error.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 07:07:04 2023 UTC