php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17092 Huge bug
Submitted: 2002-05-08 08:35 UTC Modified: 2002-05-08 08:49 UTC
From: tomas dot marklund at datortek dot orebro dot se Assigned:
Status: Not a bug Package: Variables related
PHP Version: 4.2.0 OS: Win 2000
Private report: No CVE-ID: None
 [2002-05-08 08:35 UTC] tomas dot marklund at datortek dot orebro dot se
Theres a huge huge huge huge huge huge huge bug!!! in php.ini ----

it says register_globals = off

Please dont do this to me!!!!!!!!!!!!!!!!
Dont make me go back to asp !!!!!!!!!!!!!!!

Register_globals is the most beutifull on this planet!

/Tomas

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-08 08:42 UTC] sander@php.net
If you like it, you can enable it your PHP.ini (set it to on).
See http://www.php.net/release_4_2_0.php for more info.
 [2002-05-08 08:43 UTC] tomas dot marklund at datortek dot orebro dot se
But my webhotell will not change that!!!!! in php.ini
 [2002-05-08 08:46 UTC] tomas dot marklund at datortek dot orebro dot se
Is there a way to change register_globals to on in a script??

/Tomas
 [2002-05-08 08:46 UTC] sander@php.net
Use .htaccess files or find another hoster.
 [2002-05-08 08:48 UTC] derick@php.net
It may be the most beautiful thing on the planet, it is also a big source of holes in PHP scripts.The default was changed to "Off" because of this reason.
If your webhotel wants to stay in business, they should really change this default setting to On. I'm very sure you will not be the only one which will have problems with this.
Now, to read more about register_globals, and why you should NOT use it, see the PHP 4.2.0 release announcement at www.php.net/release_4.2.0.php

regards,
Derick
 [2002-05-08 08:49 UTC] tomas dot marklund at datortek dot orebro dot se
Oppps thats something i need to learn!!!!!!!!!!
So by .htaccess i'm able to use register_globals =on
on my webhotell


I'm not giving up never,,,,,
/Tomas
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 13:01:27 2024 UTC