php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17084 PHP -i --> invalid page fault in PHP4TS.DLL
Submitted: 2002-05-07 19:01 UTC Modified: 2002-05-07 23:59 UTC
From: arnoldrt at canada dot com Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 4.2.0 OS: Windows 95
Private report: No CVE-ID: None
 [2002-05-07 19:01 UTC] arnoldrt at canada dot com
System is Windows 95 --4.00.950 B with 24 MB memory. Installed the system via the installer.

Issuing following command at the console;

php -i

resulted in aproximately 20 lines of echoed trace information (not a traceback- I have a screen shot if you need it) and the following;

PHP caused an invalid page fault in
module PHP4TS.DLL at 0137:100470dc.
Registers:
EAX=00000001 CS=0137 EIP=100470dc EFLGS=00010246
EBX=00000001 SS=013f ESP=0063fca4 EBP=00000000
ECX=007607c0 DS=013f ESI=007608a0 FS=241f
EDX=00000000 ES=013f EDI=00000001 GS=0000
Bytes at CS:EIP:
83 7d 10 03 75 10 83 7d 0c 01 75 0a 56 6a 53 68 
Stack dump:
00000001 00000000 0063fdc4 007608a0 012611a4 e9e5294a 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 014015c5 004017af 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-07 23:59 UTC] arnoldrt at canada dot com
Sorry ain't no bugs here :<
The problem was caused by a system date way in the future - 2094. The command gives the appropriate dump and direct execution of php code i.e. from the command line gives plausible results.
My problem is now that Xitami is not calling php correctly (I assume) and not getting anything back and I'll take that to the appropriate forum.
,Bob
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 05:01:23 2019 UTC